
What’s new for ProjectWise V8i 

Delta file transfer is the new ProjectWise technology that improves performance when 

sending large files over networks with high latency / low bandwidth connections, by only sending the 
changes needed to update the file, rather than the entire file. For optimal performance, use delta file 
transfer along with existing ProjectWise local file caching functionality. 

Quick Search, and the new Search toolbar  

To consolidate new and existing search tools, the Search toolbar was added to ProjectWise 
Explorer (View > Toolbar > Search), and also to document selection dialogs in integrated 
applications.  

From this toolbar users can either launch one of the existing search dialogs (Search by Form or 
Define Search, now classified as Advanced Search options) to create, run and if necessary save 
their search, or they can use the new Quick Search field. Quick Search is a “Google-like” search 
field that lets users simply type the text they want to search by and click Start search. The search 
returns all of the documents, projects, and folders that meet the search criteria. Quick searches 
are not case sensitive, and the Quick Search field stores the most recently used searches for quick 
access. 

 

 

 

 

 

 



Photo Preview  

The new Photo Preview tab in the Preview Pane is designed to let you preview image documents 
(particularly digital photographs) in ProjectWise Explorer without having to open a new 
window. When you select an image document in the document list and then select the Photo 
Preview tab in the Preview Pane, a copy of the document is downloaded to your working 
directory, and a preview of the image displays in the Photo Preview tab. 

 

ProjectWise Network Configuration Settings dialog now also 
opens from ProjectWise Explorer  

The new menu item in ProjectWise Explorer, Tools > Network Configuration Settings opens the 
ProjectWise Network Configuration Settings dialog. This dialog, which still can also be opened 
from the Control Panel, is used to set which ProjectWise servers your ProjectWise Explorer can 
connect to, and is also used to configure the new auto-login settings for integrated applications. 

 

 

 

 



More ways to open the reference scanning wizard  

You can now open the Scan for References and Link Sets wizard by: 

• selecting Folder > Scan References and Link Sets (new) 
• selecting Document > Set > Scan References and Link Sets (new) 
• selecting Tools > Scan References and Link Sets (existing) 
• right-clicking selected folders/projects and selecting Scan References and Link Sets 

(new) 
• right-clicking selected documents and selecting Set > Scan References and Link Sets 

(new) 

When you have documents and/or folders/projects selected and you use any one of the new entry 
points to open the wizard, the paths of selected documents and/or folders/projects are 
automatically added to the Select master files and folders page of the wizard. 

 

Local Document Organizer enhancement  

In previous versions, turning on the user setting, Show Local Document Organizer on log out, 
made the Local Document Organizer open (if you had documents checked out or exported) when 
you logged out of a datasource, whether you were in ProjectWise Explorer or an integrated 
application. Now this user setting has three options: you can set it so that the Local Document 
Organizer never opens on log out, opens on log out whether you are in ProjectWise Explorer or 
an integrated application, or only opens on log out when you are in ProjectWise Explorer. 

 



Cut, Copy, Paste  

New Cut, Copy, and Paste options have been added to the Document menu in ProjectWise 
Explorer. Use Document > Cut (or <ctrl-X>) and Document > Paste (or <ctrl-V>) together, to 
move the selected document(s) from one folder to another. Use Document > Copy (or <ctrl-C>) 
and Document > Paste (or <ctrl-V>) together, to create copies of the selected document(s) in the 
existing folder or in another folder. 

To differentiate from the existing Copy command in ProjectWise Explorer, the existing 
Document > Copy command has been renamed Document > Copy To. Because of this change, 
the existing Document > Move command has been renamed Document > Move To. 

Back and forward navigation buttons  

New back and forward navigation buttons let you jump quickly back and forth between 
previously selected items in the datasource. 

 

File transfer operations can now be cancelled through the 
progress bar  

There is a new user setting called User Interface - Show progress indicator during file 
transfers, which controls whether or not the progress bar displays during any ProjectWise 
Explorer operation that involves the transferring of files. When this setting is on, then during a 
file transfer, you can cancel the operation by cancelling the progress bar. If ProjectWise was in 
the middle of transferring multiple files and you cancel the operation, the operation simply stops 
right there. Any files that were successfully transferred are not affected.  

 

 

 

 



New Thumbnails view for the document list  

There is a new option, View > Thumbnails, which changes the icons in the document list to 
display thumbnail images for all the documents in the selected folder. If there is no thumbnail 
image for a particular document, then a default image displays in its place. 

 

You can also add a Thumbnails icon to the Standard toolbar (using Tools > Customize). 
Clicking the Thumbnails icon in the Standard toolbar is the same as selecting View > 
Thumbnails. 

 

The Thumbnails view is also available wherever the document list appears in a document 
selection dialog, including those in integrated applications. 

 

The thumbnails that display in the document list are the same as the thumbnails that display 
on the Document Properties tab of the Preview Pane in ProjectWise Explorer, and are 
generated by your administrator, using ProjectWise Integration Server´s Thumbnail 
Extractor. 

New document permission: Free  

ProjectWise lets you free documents you have checked out or exported, when your user setting 
Document - Free is on. This is not new and has not changed. However, there is a new document 
permission called Free, which can be set at the project, folder, or document level. This 
permission lets administrators decide on a project-by-project basis which users can free which 
documents that are checked out or exported by other users.  

Note the following when working with the new Free permission: 

• In order to free a document that is checked out or exported to another user, you must have 
the Free permission turned on for that particular document, and your user setting 
Document - Free must also be on. 

• In order to free your own checked out or exported documents, you do not need the Free 
permission to be on for those documents, you only need your user setting Document - 
Free to be on. 

 

 

 



Reference scanning enhancements  

The reference scanning wizard (Tools > Scan for References and Link Sets) can now also be 
used to: 

• create a set from newly imported shapefiles (SHP) and their related files. 
• create a set from newly imported raster files and their related file(s). 

To perform shapefile scans, no additional software or application integration is required beyond 
the installation of ProjectWise Explorer itself. To perform scans on raster files and their related 
files, you need a valid DGN scanning engine installed. 

Actions that affect shapefiles also affect their related files  

After a set is created in ProjectWise for a shapefile and its related files, or for a raster file and its 
related files, then whenever you perform an action on the main file of the set, the same action is 
performed on its related files. Actions that affect shapefiles and their related files (or raster files 
and their related files) include: check out, copy out, purge, export, delete, free, version, copy, 
move, and rename. 

Integration support added for the following applications and 
their versions  
 

• MicroStation V8i (SELECTseries 1) 
• MicroStation PowerDraft V8i (SELECTseries 1) 
• Bentley View V8i (SELECTseries 1) 
• ProjectWise Navigator V8i (SELECTseries 1) 
• ProjectWise i-model Composer V8i (SELECTseries 1) 
• Microsoft Office 2007 SP2 
• MicroStation V8i (SELECTseries 2) 
• MicroStation PowerDraft V8i (SELECTseries 2) 
• Bentley View V8i (SELECTseries 2) 
• ProjectWise Navigator V8i (SELECTseries 2) 
• ProjectWise i-model Composer V8i (SELECTseries 2) 
• AutoCAD 2010 (32-bit) (Update2) 

 

 



MicroStation integration enhancements  
 

• ProjectWise V8i included support for MicroStation V8i's new Print Organizer dialog, 
however you could only run .PSET print jobs from MicroStation. ProjectWise V8i 
(SELECTseries 1) extends the support of Print Organizer, so that you can now run .PSET 
print jobs from ProjectWise Explorer. 

• Support for shapefiles as references — ESRI shapefiles can now be attached as vector 
references, in integrated MicroStation V8i (SELECTseries 1). 

• When you are in integrated MicroStation V8i (SELECTseries 1) and you attach a 
shapefile to your DGN, ProjectWise will create two sets — one for the relationship 
between the master DGN and the attached shapefile, and one for the relationship between 
the shapefile and its own related files. Similarly, when you attach a raster file to your 
DGN, and that raster file has its own related files (whether a world file or some other 
file(s)), ProjectWise again will create two sets — one for the relationship between the 
master DGN and the attached raster file, and one for the relationship between the raster 
file and its own related file(s). 

• ProjectWise supports the dynamic views enhancements of MicroStation V8i 
(SELECTseries 1), which allow for the automated creation of new drawing models, sheet 
models, saved views, or references from a portion of an existing document. Integration 
with ProjectWise allows those new models to be stored inside ProjectWise. Specifically, 
the new model, saved view, or reference can be stored inside the same document, inside 
some other existing document, or inside a new document altogether. 

• The document list in File-Open dialogs can now be filtered by file extension. 
• In managed workspaces, a new level called Predefined is added to the top of the 

processing order for configuration settings blocks. This level gives users the ability to set 
predefined variables in MicroStation managed workspaces. Variables assigned to the 
Predefined level will be processed before the MicroStation local configuration is 
gathered. 

 

 

 

 

 

 



AutoCAD integration enhancements  
 

• New command, ProjectWise > Place On Sheet (DMSPLACEONSHEET) 

• There is a new DMSSET variable called SHOWMISSINGSHAPES, which is used to 
control what action integrated AutoCAD takes when you open a document that has 
missing SHX files. 

• There is a new DMSSET variable called SHEETSETMODE, which is used to control 
whether or not AutoCAD Sheet Set functionality is integrated with ProjectWise. 

• ProjectWise now provides integration with AutoCAD's File > eTransmit feature, which 
lets you package the current DWG file and its related dependent files (such as external 
references and font files) inside a single ZIP file, and store it in the datasource. You can 
turn the integration for this feature on or off through the new DMSSET variable called 
ETRANSMITMODE 

• There is now a Recent Documents / Most Used Documents view in ProjectWise Session 
File Manager. When the Recent Documents view is active, a thumbnail image is 
displayed for each of the ProjectWise documents you have had open from the current and 
previous sessions of integrated AutoCAD. If you then switch to the Most Used 
Documents view, then the documents are rearranged to list the most recently used 
documents in the order they are most frequently used. As the list grows, you can clear the 
Recent Documents / Most Used Documents view as needed. 

• Reorganization and renaming of some items on the ProjectWise menu 
• In integrated AutoCAD 2010, there is a ProjectWise tab on the AutoCAD ribbon bar. 

 

 

Managed workspace performance improvement  
 

The time it takes to validate a managed workspace when opening a document, when the 
workspace is already copied out, has been significantly reduced. 
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